• Eager Eagle
    link
    fedilink
    English
    20
    edit-2
    1 year ago

    The liberty to not name things that are obvious.

    and that’s yet another way to end up with hard to read code.

    Variables hold values that have meaning. Learn how to name things and you’ll write good code.

    edit: someone just wrote an article along these lines. The only thing I’d change is the cause-effect relationship between bad names and bad code. IME bad names lead to bad code, not usually the other way around. The reason is that by starting from good name choices, it’s much easier to have a well structured code. And not rarely, bad names lead to mangled up code that screams for a refactoring.

    • @[email protected]
      link
      fedilink
      01 year ago

      This makes me want to write a function for you to add to numbers where the variables are leftumber and rightnumber, instead of x and y.

      • Eager Eagle
        link
        fedilink
        English
        51 year ago

        if “left” and “right” were relevant for addition, they would indeed be better names

            • @[email protected]
              link
              fedilink
              11 year ago

              To each their own. But man imagine if you have a collection of stuff that has a large name, and then having to figure out a short name other than e when iterating. I hope you’re not iterating over chemical names 😬

              • Eager Eagle
                link
                fedilink
                English
                41 year ago

                No need to be over-descriptive. Anything at all more specific than e will probably be a better name

              • @Kalabasa
                link
                English
                11 year ago

                It’s not black and white. I mean, even el is a lot better than e.

          • @noli
            link
            1
            edit-2
            1 year ago

            Depends. If you’re using a good ol’ C-style for loop then nothing’s wrong with for(int i = 0; i < something;i++), but if you’re doing something like iterating over some collection it’s way clearer to do something like for animal in animals: than it is to do for e in animals:. Especially if you’re doing something non-trivial for each element

      • Turun
        link
        fedilink
        11 year ago

        Implementing add (and other math operations) in rust for your types has the type signature self and rhs (right hand side).

        • @[email protected]
          link
          fedilink
          21 year ago

          In what way? If you encountered a function that had x and y which just added them together, that’s not readable enough?

          • @[email protected]
            link
            fedilink
            11 year ago

            Well in a vacuum yes sure, you’re right, but in practice there’s always some context. x and y could be referring to axes, where an addition makes little sense. However lhs and rhs make more sense if you’re overloading an operator