Somewhere between API resources, queue workers, repositories, clients and serializers there is a class of … classes/modules that does the needful. Gun-to-my-head, I would call them “services” but I’m looking for a less overloaded term. Maybe capabilities? Controllers? Pick a term from the business domain? What do you call them?

  • tatterdemalion
    link
    fedilink
    arrow-up
    4
    ·
    6 months ago

    Stealing from “Domain Driven Design”, I think calling them “domain objects” is appropriate.

    • vvvOP
      link
      fedilink
      arrow-up
      1
      ·
      6 months ago

      that’s a good call actually. I got pretty hung up on domain objects being mostly data classes, but one approach is to have them perform business logic themselves.

      • tatterdemalion
        link
        fedilink
        arrow-up
        1
        ·
        6 months ago

        Perhaps “domain modules” if you want to be more agnostic about the actual shape of the code.