Whenever you store a value that has a unit in a variable, config option or CLI switch, include the unit in the name. So:

  • maxRequestSize => maxRequestSizeBytes
  • elapsedTime => elapsedSeconds
  • cacheSize => cacheSizeMB
  • chargingTime => chargingTimeHours
  • fileSizeLimit => fileSizeLimitGB
  • temperatureThreshold => temperatureThresholdCelsius
  • diskSpace => diskSpaceTerabytes
  • flightAltitude => flightAltitudeFeet
  • monitorRefreshRate => monitorRefreshRateHz
  • serverResponseTimeout => serverResponseTimeoutMs
  • connectionSpeed => connectionSpeedMbps

EDIT: I know it’s better to use types to represent units. Please don’t write yet another comment about it. You can find my response to that point here: https://programming.dev/comment/219329

  • mirisbowring
    link
    fedilink
    English
    31 year ago

    But what if the FileSize can be „1G“, „1024M“, 518K“, etc.?

    Documentation itself is much more important and modern IDEs and Editors will show you what to type in :)

    • 𝕊𝕚𝕤𝕪𝕡𝕙𝕖𝕒𝕟OP
      link
      English
      51 year ago

      In that case I would call the variable fileSizeWithUnit and also document what the possible units are. I wouldn’t say that documentation is categorically more important than good naming. Both are different aspects of good software development.

    • @starman
      link
      English
      41 year ago

      Then use bytes