Hellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 2 months agoTIFU by not using objects in my object-oriented programming courseworklemmy.caimagemessage-square24fedilinkarrow-up179arrow-down18cross-posted to: programmer_humor
arrow-up171arrow-down1imageTIFU by not using objects in my object-oriented programming courseworklemmy.caHellfire103@lemmy.ca to Programmer Humor@lemmy.mlEnglish · 2 months agomessage-square24fedilinkcross-posted to: programmer_humor
minus-squareddplf@szmer.infolinkfedilinkarrow-up4arrow-down12·2 months agoGood, OOP can suck my balls
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up13arrow-down1·2 months agoBalls.suck() is the correct syntax.
minus-squareRagingToad@feddit.nllinkfedilinkarrow-up5·2 months agoDon’t you need to declare new Balls() first? Or do you suck() Balls static?
minus-squarexigoi@lemmy.sdf.orglinkfedilinkEnglisharrow-up9·edit-22 months agoBallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up10·edit-22 months agoAll of this is okay, but it’s not production ready. This is what real production code looks like: SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
minus-squarewhats_all_this_then@lemmy.worldlinkfedilinkarrow-up13·2 months agoPython port: from ballsucker import suck suck()
minus-squarevext01@lemmy.sdf.orglinkfedilinkarrow-up3·2 months agoOr I didn’t using the correct naming convention!
minus-squareluciferofastora@lemmy.ziplinkfedilinkarrow-up2·2 months agoActually, it would be OOP.suck(ddplf.getBalls())
Good, OOP can suck my balls
Balls.suck() is the correct syntax.
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Or I didn’t using the correct naming convention!
Actually, it would be
OOP.suck(ddplf.getBalls())