• OADINC
    link
    fedilink
    54
    edit-2
    1 year ago

    This is the only way;

    if (condition) {
        code
    }
    

    Not

    if (condition)
    {
        code
    }
    

    Also because of my dyslexia I prefer variable & function names like this; ‘File_Acces’ I find it easier to read than ‘fileAcces’

    • @[email protected]
      link
      fedilink
      English
      51 year ago

      I think it would be a much hotter take if you had the opposite opinion. I’ve only met a few of those.

      • Evilsandwichman [none/use name]
        link
        fedilink
        English
        21 year ago

        I’m not a programmer (I tried learning programming and unity but got lazy so…) but when I learned about if-then statements, the second one seemed like the way it’s supposed to be; I mean it looks so clean and simple. Do actual programmers prefer the first method?

        • Ethan
          link
          English
          41 year ago

          I prefer the first method because it reduces the number of empty lines I have to scroll past and visually filter out

        • @coloredgrayscale
          link
          21 year ago

          The 2nd is the style guide used in C#, and therefore what you’ve encountered in unity.

    • owlet
      link
      fedilink
      4
      edit-2
      1 year ago

      I’ve only seen the second type in C#, to be fair it makes code neater but i’m glad I left it for Java.

      • @[email protected]
        link
        fedilink
        21 year ago

        How does it make code neater? All it does is add a ton of empty vertical space. It makes files arbitrarily longer at essentially no benefit.

    • AItoothbrush
      link
      fedilink
      English
      31 year ago

      It depends for me. If the condition is some goofy ahh multiline syntax hell i like to use the second option.

    • alcoholicorn [comrade/them, doe/deer]
      link
      fedilink
      English
      2
      edit-2
      1 year ago

      I use all 3.

      If it’s very short and there’s 2 or more in a row, I’ll put it all in one line.

      If there’s a bunch of nested if statements, I’ll use the second.

      If neither of those conditons, I’ll use the first.