Both zig and go use the dot operator, but I find the ‘::’ operator much more readable.

Vec::new();

Makes it clear that were accessing a static method belonging to the Vec struct/namespace.

Vec.new()

Makes it seem like Vec is an object with a ‘new’ method.

Am I alone in thinking this?

  • eluvatar
    link
    fedilink
    arrow-up
    6
    ·
    11 months ago

    I like how Java uses it. As a C# dev I wish for it sometimes.