Hey everyone, update on https://programming.dev/post/4613085

We did some changes in the database and it seems like outbound federation is working again. If you run into any more problems with it let us know.

Im pinning this post for around a day to let everyone know since we had the last post pinned for a bit

Any posts or comments made while it was broken still wont be federated but new ones should be. The instance essentially marked all other instances as dead which meant it thought it didn’t have to send things to them

  • silas
    link
    English
    94 months ago

    Donut of appreciation attached below:

          🍩

     

  • @aport
    link
    84 months ago

    Haha now the rest of the fediverse is subject to my stupid comments!

  • fmstrat
    link
    fedilink
    English
    24 months ago

    Curiosity, was it not loading the custom config?

    • AtegonOPMA
      link
      24 months ago

      yeah it broke again for a bit, getting that up rn. Seems to be that the instance isnt automatically marking things alive so after 3 days everything is marked as dead again

      • Deebster
        link
        English
        14 months ago

        Is it a problem their end or this end? I thought the issue was that the outgoing server (ours, in this case) wasn’t federating things outwards because it mistakenly believed the recipient was dead.

        • AtegonOPMA
          link
          1
          edit-2
          4 months ago

          yeah its our end and thats why. Federation should be fixed now (things posted when down wont be federated still but new things will. Were setting up a cron job now to get this updated every day so it shouldnt be a problem any more)

          After 3 days of no response lemmy considers things dead but the issue is is its not checking for a response

          • Deebster
            link
            English
            14 months ago

            ok, thanks for that, I think I just misunderstood which instance you were talking about when you said “the instance”.

            A related question you might be able to answer: if I search from the recipient’s end and pull over a post that way, is it then federated out by that recipient instance? Or is it better to just delete and repost?

            • snoweMA
              link
              24 months ago

              I am not sure. It might just be best to try. Federation should be very quick these days so if you’re not seeing something in a minute or two then something is most likely wrong.

    • AtegonOPMA
      link
      24 months ago

      Everything seems to be fine in the database so not sure why that wouldnt propagate. Ill do some testing

    • AtegonOPMA
      link
      24 months ago

      Looks like that post was made when federation was broken (there was a small window 14 days ago when it went down again) so itll still have issues with federating comments. Recent posts and comments in the community seem to still be fine

      • @[email protected]
        link
        fedilink
        English
        14 months ago

        My reply from my programming.dev account to the person on Lemmy.world was made yesterday. It still hasn’t propagated.

        I had to reply using my Lemmy.world account. That reply federated to programming.dev. It looks like it’s going in one direction only?

        • AtegonOPMA
          link
          2
          edit-2
          4 months ago

          yeah federation broke one way only when it was broken. Replies on broken posts from here wont propagate no matter when its done