var Turtle1 var Turtle2 var Is_Turtle

  • @parpol
    link
    23
    edit-2
    6 days ago

    Yeah, a name should describe what it is or does, so if you have two turtles, and let’s say turtle1 wants to shit on turtle2’s lawn, you could name them shittingTurtle and victimTurtle. If the name alone tells you what its purpose is, that saves a lot of time for people looking at your code.

    Is_Turtle is not a bad variable name because it tells you it is a Boolean with “is” and that the Boolean tells you whether something is a turtle or not.

    Also, depending on the language, I suggest either camelCase or snake_case naming of variables. PascalCase is usually for defining classes or in case of C#, methods.

    • Repple (she/her)
      link
      fedilink
      126 days ago

      SHOUTING_SNAKE_CASE aka SCREAMING_SNAKE_CASE is the best case for all use cases, because it gives you a chance to use its wonderful names.

        • @MajorHavoc
          link
          8
          edit-2
          5 days ago

          Thanks. I hate it.

          I consider myself a collector of programming anti-patterns, but I didn’t have this one yet.

    • @MajorHavoc
      link
      35 days ago

      Thank you for this. This is awesome.

      shittingTurtle and victimTurtle are going into one of my professional slide decks as soon as I think I can get away with it.

    • @[email protected]OP
      link
      fedilink
      4
      edit-2
      6 days ago

      I’m gonna be honest I just used Turtle ad an example:X … when it’s actually like a GoldCost, GoldC and GoldH. Where GoldR is a reset var and GoldC is the paid value. GoldCost is self explanatory but I really spagettied it up XD…