var Turtle1 var Turtle2 var Is_Turtle

  • r00ty
    link
    fedilink
    107 days ago

    An array?

    var turtles = new Turtle[] { new Turtle(), new Turtle() };

    Don’t do this :P

  • @[email protected]
    link
    fedilink
    25 days ago

    I remember an old mentor programmer I had who basically described his job as building an addition to an addition to an addition on a tree house built in a twig.

    • @[email protected]
      link
      fedilink
      English
      57 days ago

      What’s wrong with making a recursive function in a recursive function with variables M, m, N, n? It’s perfectly fine when I’m writing infinite series.

      • @[email protected]
        link
        fedilink
        17 days ago

        If we’re talking mathematicians, you just know it’s going to be ω-nested recursive functions any moment now. Just be grateful it’s not all n with polynomial subscripts or something.

        • @[email protected]
          link
          fedilink
          English
          17 days ago

          Polynomial subscripts sound awesome, ngl. Never seen it before; I want to know what the applications are.

          • @[email protected]
            link
            fedilink
            1
            edit-2
            6 days ago

            Uhh, I’m pretty sure I’ve seen that, but I’m not sure where now. Any time you need to access a member of a list or array that’s determined by a polynomial - which by Horner’s rule covers all combinations of multiplications and additions - it would be a possible notation.

            Transfinite algorithms are definitely a topic of research.

  • @MajorHavoc
    link
    37 days ago

    All great code started out as a shitty work-around that happened to work.

    (I say this as someone with one of the more prestigious pedigrees in “not writing shit code”. All the theory I’ve learned helps, but at the end of the day the most important qualities of a line of code are: whether it got the job done, and whether is was obviously correct enough that the next developer left it alone.)

  • @[email protected]
    link
    fedilink
    37 days ago

    Because I mostly (almost exclusively) write shell scripts, my vars are often like this: theList, workingDir, etc.

    I’m a monster. But it works for me.

  • @[email protected]
    link
    fedilink
    37 days ago

    This is a very cute thread. I love turtles and I like them for their vast computer science skills too.

  • Codex
    link
    fedilink
    27 days ago

    All these jokes about naming variables and yet no serious suggestions that if you have a turtle2, what you really need is a turtle array. I like to block out all the memory I’ll need for the whole program up front, put it all in one big array, and then I can use clean, easy to remember numbers for all my variables!

  • @[email protected]
    link
    fedilink
    English
    477 days ago

    Try assembly language! You have registers, and they are named for you with highly memorable names like R17.

  • @parpol
    link
    23
    edit-2
    7 days ago

    Yeah, a name should describe what it is or does, so if you have two turtles, and let’s say turtle1 wants to shit on turtle2’s lawn, you could name them shittingTurtle and victimTurtle. If the name alone tells you what its purpose is, that saves a lot of time for people looking at your code.

    Is_Turtle is not a bad variable name because it tells you it is a Boolean with “is” and that the Boolean tells you whether something is a turtle or not.

    Also, depending on the language, I suggest either camelCase or snake_case naming of variables. PascalCase is usually for defining classes or in case of C#, methods.

    • @MajorHavoc
      link
      36 days ago

      Thank you for this. This is awesome.

      shittingTurtle and victimTurtle are going into one of my professional slide decks as soon as I think I can get away with it.

    • Repple (she/her)
      link
      fedilink
      127 days ago

      SHOUTING_SNAKE_CASE aka SCREAMING_SNAKE_CASE is the best case for all use cases, because it gives you a chance to use its wonderful names.

        • @MajorHavoc
          link
          8
          edit-2
          7 days ago

          Thanks. I hate it.

          I consider myself a collector of programming anti-patterns, but I didn’t have this one yet.

    • @[email protected]OP
      link
      fedilink
      4
      edit-2
      7 days ago

      I’m gonna be honest I just used Turtle ad an example:X … when it’s actually like a GoldCost, GoldC and GoldH. Where GoldR is a reset var and GoldC is the paid value. GoldCost is self explanatory but I really spagettied it up XD…

      • @[email protected]
        link
        fedilink
        11
        edit-2
        7 days ago

        Have you considered multiple inheritance. It’s an upgrade. All upside, literally no downside. I’m trustworthy. Trust me.

        • KeriKitty (They(/It))
          link
          fedilink
          English
          57 days ago

          Idunno, my mom told me not to talk to _stranger_s 🤔

          … She said a lot of things that were BS, though, so maybe you’re cool I guess? 🤷

          • @MajorHavoc
            link
            27 days ago

            Wow. “peak shareholder value” is what I shall now call “multiple inheritance”, from now on.

      • @[email protected]
        link
        fedilink
        3
        edit-2
        7 days ago

        Inheritance established “is a” relationship between classes.

        class Turtle;  
        class TigerTurtle is a Turtle (but better);  
        class BossTurtle is a Turtle (but better);  
        

        Underlying classes hold an inner object to the super class, everything from Turtle will be in TigerTurtle and BossTurtle.

        In some languages that is configurable with public, private, protected keywords.

        Relatedly, there’s also composition, which establishes a “has a” relationship:

        class TurtleTail;
        class Turtle:
          var tail: TurtleTail; (has a tail);
        

        Since Turtle is NOT a tail, but a whole animal, turtle should not inherit TurtleTail. But it HAS a tail, thus we add turtle tail as a property.

        • @[email protected]
          link
          fedilink
          3
          edit-2
          7 days ago

          I’m only commenting because the actual python is practically pseudo code:

          
          # A turtle class
          class Turtle:
              shell=True
          
          # A boss class
          class Boss:
              authority=True
          
          #A class that inherits from another
          class TigerTurtle(Turtle):
              fuzzy=True
          
          # Multiple inheritance, or "The Devil's Playground"
          class TigerBossTurtle(TigerTurtle, Boss):
              #  shell, authority, and fuzzy are all true
              ...
          
      • Dr. Wesker
        link
        fedilink
        English
        6
        edit-2
        7 days ago

        When you start learning about different paradigms, you’ll likely learn much more about inheritance when learning about the Object Oriented design paradigm.

        To overly simplify, you create objects that inherit attributes from other objects. It’s for instance a way to create reusable patterns, that have stronger and more reliable data structures.

        I made the joke comment, because for instance, you could create a Turtle class, and always know it was a Turtle. Again, an oversimplification.

        EDIT: I should also add that for some reason OOP is an oddly divisive subject. Developers always seem to want to argue about it.

          • @MajorHavoc
            link
            17 days ago

            At this point I think there is no software dev topic that is somehow not devisive.

            Now I want to try something:

            “Boolean variables don’t suck.”

            • @[email protected]
              link
              fedilink
              2
              edit-2
              7 days ago

              No one uses Boolean values anyway and with the amount of resources available on modern systems we can just replace them with integers and we should be fine. This also makes it easier to teach people, as they would learn less different data types.

              Yes I’m a software dev :)

          • @arendjr
            link
            37 days ago

            Just keep in mind that inheritance is nowadays a very contested feature. Even most people still invested in object oriented programming recognise that in hindsight inheritance was mostly a mistake. The industry as a whole is also making a shift to move more towards functional programming, in which object orientation as a whole is taking more of a backseat and inheritance specifically is not even supported anymore. So yeah, take the chance to learn, but be cautious before going into any one direction too deeply.

            • magic_lobster_party
              link
              fedilink
              17 days ago

              I like to mix between OOP and FP for different levels. OOP is great for higher architectural problems. FP is great for everything under it.

              And yes, inheritance was a huge mistake. Just use composition and interfaces instead.

          • Dr. Wesker
            link
            fedilink
            English
            1
            edit-2
            7 days ago

            If I could give a suggestion I wish I had gotten much earlier on in my education and career, it would be to really spend some time learning about the different paradigms, and their best use cases. You will likely ensure yourself a strong foundation in software architecture.

            • @[email protected]OP
              link
              fedilink
              17 days ago

              I’ll check it out! I’m very casual and doing thus mostly as a passion/Fun project. But I love any direction thank you:)

  • 🇰 🌀 🇱 🇦 🇳 🇦 🇰 ℹ️
    link
    fedilink
    English
    4
    edit-2
    7 days ago

    I always make sure my variables are named in ways I can remember what they’re for. The only time I just use generic var1, var2, etc is if I am experimenting with a function I’ve never used before and wanna play around with it to see how it’s used.

    This should be easily read by others but there could be times where it’s an inside joke.

  • @[email protected]
    link
    fedilink
    English
    27 days ago

    Yes your variable names should indeed all be different from one another.

    var Turtle1 var Turtle1 var Turtle1

    just doesn’t quite have the same impact:-).