• Python
    link
    fedilink
    arrow-up
    18
    ·
    2 months ago

    smh, could have used the short form ()=>{ instead of function 😤

    • Deebster
      link
      fedilink
      English
      arrow-up
      11
      ·
      2 months ago

      I’ve been coding long enough that I still think of that as a fairly new thing in JS.

    • PoolloverNathan
      link
      fedilink
      arrow-up
      7
      ·
      2 months ago

      Someone’s handed me nested base-64 encoded JSON before and to this day I am moderately annoyed at them.

      • MinekPo1 [it/she]@lemmygrad.ml
        link
        fedilink
        arrow-up
        2
        ·
        2 months ago

        unity kinda does this ! there is a json file wirh a base-64 encoded string (UTF-16 encoding) and is a completely different data structure with embedded json

        • PoolloverNathan
          link
          fedilink
          arrow-up
          2
          ·
          2 months ago

          I just had to add URL-encoded TOML to something due to a certain Rust crate’s constraints.

  • zygo_histo_morpheus
    link
    fedilink
    arrow-up
    11
    ·
    2 months ago

    Why settle on cammel case (“saveGame”) or upper cammel case (“SaveGame”) when you can have one of each?

  • Kissaki
    link
    fedilink
    English
    arrow-up
    11
    ·
    2 months ago

    In German we say “doppelt hält besser”. Is there an English saying like that? “Twice is stronger/more stable/holds better.”

      • Hello Hotel@lemmy.world
        link
        fedilink
        English
        arrow-up
        1
        ·
        edit-2
        4 days ago

        This is just as easy to write, just as sloppy but hopefully way easier to read.

        Game.onload = (data)=>{
        let a = data;
        a = JSON.decode(a)["saveGame"][0];
        a = JSON.decode(a)["SaveGame"];
        return a;
        }
        
      • logging_strict
        link
        fedilink
        arrow-up
        1
        ·
        2 months ago

        … an adult enters the conversation ;-)

        Easier maintainability is everything

        The best code

        Comes with tests what are easy to understand. As bugs are discovered, should be written in such a way, that it’s very easy to add more test cases.

        Fewest lines is not necessarily easy to maintain.